Gtk-rs documentation

Requirements

Crate API docs

Versions

By default the gtk crate provides only GTK+ 3.4 APIs. You can access more modern APIs by selecting one of the following features: v3_6, v3_8, v3_10, v3_12, v3_14, v3_16.

Cargo.toml example:

[dependencies.gtk]
version = "0.1.0"
features = ["v3_16"]

Take care when choosing the version to target: some of your users might not have easy access to the latest ones. The higher the version, the fewer users will have it installed.

Examples

See the examples repository.

The GTK+ Project documentation